Boolean Expressions — 递归

A:Boolean Expressions

总时间限制: 1000ms 内存限制: 65536kB

描述

The objective of the program you are going to produce is to evaluate boolean expressions as the one shown next:
Expression: ( V | V ) & F & ( F | V )
where V is for True, and F is for False. The expressions may include the following operators: ! for not , & for and, | for or , the use of parenthesis for operations grouping is also allowed.

To perform the evaluation of an expression, it will be considered the priority of the operators, the not having the highest, and the or the lowest. The program must yield V or F , as the result for each expression in the input file.

输入

The expressions are of a variable length, although will never exceed 100 symbols. Symbols may be separated by any number of spaces or no spaces at all, therefore, the total length of an expression, as a number of characters, is unknown.

The number of expressions in the input file is variable and will never be greater than 20. Each expression is presented in a new line, as shown below.

输出

For each test expression, print “Expression ” followed by its sequence number, “: “, and the resulting value of the corresponding test expression. Separate the output for consecutive test expressions with a new line.

Use the same format as that shown in the sample output shown below.

样例输入

( V | V ) & F & ( F| V)
!V | V & V & !F & (F | V ) & (!F | F | !V & V)
(F&F|V|!V&!F&!(F|F&V))

样例输出

Expression 1: F
Expression 2: V
Expression 3: V

来源México and Central America 2004

本来想粘一发代码,结果发现网上的又长又丑(逃,就自己写了下
就是一个简单递归,记录几个变量,匹配一下括号(然后我都直接用的全局变量递归qaq

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
#define N 220
char s[N];
int n,T,x;
bool mk(bool a,bool b,bool op){
    if(op) return a&b;
    else return a|b;
}
bool get(){
    bool tp=0,nf=0,op=0;
    while(x<n){
        if(s[x]=='!') nf=1,++x;
        else if(s[x]=='(') ++x,tp=mk(tp,get()^nf,op),nf=op=0;
        else if(s[x]==')'){++x;return tp;}
        else if(s[x]=='|') op=0,++x;
        else if(s[x]=='&') op=1,++x;
        else if(s[x]=='V') tp=mk(tp,1^nf,op),nf=op=0,++x;
        else if(s[x]=='F') tp=mk(tp,0^nf,op),nf=op=0,++x;
        else ++x;
    }
    return tp;
}
int main()
{
    while(cin.getline(s,200)){
        n=strlen(s);++T;x=0;
        printf("Expression %d: %c\n",T,get()?'V':'F');
    }
    return 0;
}

评论

还没有任何评论,你来说两句吧

发表评论

衫小寨 出品