bzoj 1677: [Usaco2005 Jan]Sumsets 求和

 

1677: [Usaco2005 Jan]Sumsets 求和

Time Limit: 5 Sec  Memory Limit: 64 MB

Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7: 1) 1+1+1+1+1+1+1 2) 1+1+1+1+1+2 3) 1+1+1+2+2 4) 1+1+1+4 5) 1+2+2+2 6) 1+2+4 Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).

给出一个N(1N10^6),使用一些2的若干次幂的数相加来求之.问有多少种方法

Input

   一个整数N.

Output

方法数.这个数可能很大,请输出其在十进制下的最后9位.

Sample Input

7

 

Sample Output

6

有以下六种方式
1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

HINT

Source

dp动归,关于是否为偶数分两类讨论

#include<cstdio>
#define mod 1000000000
#define F(i,l,r) for(int i=l;i<=r;i++)
int dp[1000010],n;
int main()
{
    dp[1]=1;
    scanf("%d",&n);
    F(i,2,n)
    {
        if(i&1) dp[i]=dp[i-1];
        else dp[i]=(dp[i-1]+dp[i>>1])%mod;
    }
    printf("%d",dp[n]);
}

 

 

评论

还没有任何评论,你来说两句吧

发表评论

衫小寨 出品